Burgman K9 UH125 multiple issues

austieman
Posts: 10
Joined: Fri Jun 28, 2019 2:04 am
Current Ride: Suzuki Burgman 125UH 08
Great Britain
Re: Burgman K9 UH125 multiple issues

Post by austieman » Wed Aug 21, 2019 1:20 pm

Sorry meant to add 2 images. Here are both of them.
IMG_0297.jpg
IMG_0298.jpg

Sent from my iPhone using Tapatalk

austieman
Posts: 10
Joined: Fri Jun 28, 2019 2:04 am
Current Ride: Suzuki Burgman 125UH 08
Great Britain
Re: Burgman K9 UH125 multiple issues

Post by austieman » Thu Aug 22, 2019 4:30 am

Ralph wrote:If you have a removable baffle for it try fitting it.
I don't have anything for the exhaust. I bought the bike with it fitted.
I'm coming to the conclusion that there won't be much of an option other than to buy a new exhaust which I'm hesitant to do since it's so expensive compared to the value of the bike.
Re. Cleaning the brake caliper, hopefully I can find some time to do that this weekend.


Sent from my iPhone using Tapatalk

User avatar
Ralph
Posts: 773
Joined: Fri Jun 01, 2012 7:20 am
Current Ride: Yamaha X-max 300 300
Location: Near Fleetwood
England
Re: Burgman K9 UH125 multiple issues

Post by Ralph » Thu Aug 22, 2019 7:08 am

Have a look on Evil bay you may come across a good org exhaust that as been removed to fit something else.
Ralph
Nr Fleetwood
Yamaha X-max 300
Ariel NH 350
Ariel WNG 350


icon_maxi_scoot.gif


Image

austieman
Posts: 10
Joined: Fri Jun 28, 2019 2:04 am
Current Ride: Suzuki Burgman 125UH 08
Great Britain
Re: Burgman K9 UH125 multiple issues

Post by austieman » Thu Aug 22, 2019 10:20 am

Ralph wrote:Have a look on Evil bay you may come across a good org exhaust that as been removed to fit something else.
I'll keep an eye out but it looks like slim pickings at the moment. Lots of options for the larger versions but not much for the 125.
Long term plan is to move it on and get something bigger so might just hold out until then.


Sent from my iPhone using Tapatalk

User avatar
Ralph
Posts: 773
Joined: Fri Jun 01, 2012 7:20 am
Current Ride: Yamaha X-max 300 300
Location: Near Fleetwood
England
Re: Burgman K9 UH125 multiple issues

Post by Ralph » Thu Aug 22, 2019 1:30 pm

Looking at the silencer the innards seem to be held by a big circlip maybe if they will come out you could repack the silencer
with something, even temporarily just for a test.
Ralph
Nr Fleetwood
Yamaha X-max 300
Ariel NH 350
Ariel WNG 350


icon_maxi_scoot.gif


Image

austieman
Posts: 10
Joined: Fri Jun 28, 2019 2:04 am
Current Ride: Suzuki Burgman 125UH 08
Great Britain
Re: Burgman K9 UH125 multiple issues

Post by austieman » Thu Aug 29, 2019 4:49 am

So I thought I would share an update on the issues that I raised in my initial post.
I spent a few hours of the bank holiday weekend cleaning the rear brake caliper on the bike as well as disconnecting the undersest light. Now I havn't mentioned an issue with the light because I didn't think it it to be much of an issue. But to summarise, up until the weekend I had been taking a fuse out after every ride to stop the battery from draining because the switch under the seat that turned the underseat light off was not being fully depressed, thus leaving the light on all the time.
In any case it is now disconnected and I am no longer taking out a fuse to save the battery. Also the back wheel is now turning more freely and the brakes don't seem to be catching at all.
Both of these things have resulted in the bike running a lot better than it ever has, and also stopping the FI light from coming on.
I'm not sure how this can be the case (maybe someone can shed some light on it) but this is the best the bike has run since I got it.
Thanks to those who offered advice!


Sent from my iPhone using Tapatalk


Post Reply